Infiniti Q50 Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-8 of 8 Results
  1. FAQ and Troubleshooting
    I've owned my Q50 Luxe AWD for about 3 months and it's the love of my life. However, the summer heat in the northeast can get into the 90s. After researching I know that a heat exchanger is necessary and if I want to do any more than 1 pull a day, I'll need one. That being said I've called about...
  2. Q50 General Discussion Forum
    My oil temp reaches up to 210 after a couple of pulls, then back down after 10mins of driving is that normal?
  3. Q50 General Discussion Forum
    Just had some general questions. 1. I have installed some HKS Blow Off Valves from Z1 motorsports over the weekend. Long story short I ended up having to take apart a coolant line which spilled coolant and required me to bleed the system(I guess). I have a vacuum lift kit but I don't know if I...
  4. 3.0t
    So I noticed my multi way control valve is leaking on my 17 q50RS. As shown in pic below. After doing research I am seeing this part in only few places. Can I just take the top of & reseal it myself? Or the only way to fix this is to replace the part?
  5. Engine and Technical Discussion
    Hello everybody, My Q50 is nearing 60k (currently at 53k miles). I am planning on keeping this car till the wheels fall off so I want to be meticulous with maintenance. I currently change the oil at 5k intervals. Therefore I have a few questions: Should I do a transmission flush or a...
  6. Q50 General Discussion Forum
    Hey guys, Just came back from an oil change on my 2017 Q50S. I got quoted $510 for a coolant leak from the thermostat housing. I have a few questions: Is this common for the VR30? Can I fix it myself? Does anyone know the fix for this?? I attached photos of the issue, as well as the quote...
  7. Engine and Technical Discussion
    Hey guys, Just came back from an oil change on my 2017 Q50S. I got quoted $510 for a coolant leak from the thermostat multi-way control valve housing. I have a few questions: Is this common for the VR30? Can I fix it myself? Does anyone know the fix for this?? I attached photos of the issue, as...
  8. Q50 General Discussion Forum
    I’m currently running my base map with seb from specialty z right now..my logs look good except my charge air coolant temperature is not moving at all. Its Been reading 70 or 75 from my cold start and and does not change through heavy load ( 2500 Rpm to redline ) ....I’ve done 3-4 runs one...
1-8 of 8 Results
Top