Infiniti Q50 Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Recently while driving and usually when making sharp right turns, the Nav and radio displays black out and reboot and I lose nav and radio connections and dropped Bluetooth calls. This has happened 4-5 times over last several months. Dealer has been unable to replicate and cannot find anything wrong with the electrical system. They suggested that I make note of what was on at the time and take a picture of the display. Only had radio on and/or was on a bluetooth call each time this happened. Has anyone had this happen to their Q50? Any ideas, suggestions as to the cause?
 

·
Registered
Joined
·
32 Posts
This happens to my 2015 Q50 (premium, with nav) whenever I have my phone plugged in as an iPod. Unplug your phone and just use Bluetooth audio. That's the only solution I've found (other than perhaps replacing the entire infotainment system at an exorbitant cost).
 

·
Registered
Joined
·
299 Posts
I have the same problem in my 2016 RS. my local dealership acted like they had never heard of it before so I had to show them a video of it. I recorded it when it happened since I can't duplicate the issue on demand. All they did was document my issue and told me to bring it back as soon as it is happening so they can see it and try to locate the issue.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
I have the same problem in my 2016 RS. my local dealership acted like they had never heard of it before so I had to show them a video of it. I recorded it when it happened since I can't duplicate the issue on demand. All they did was document my issue and told me to bring it back as soon as it is happening so they can see it and try to locate the issue.
They told me the same thing...like I can drop everything I'm doing and run there...let's see....:unsure:....No!
 

·
Registered
Joined
·
406 Posts
Happened to me two or three times in the first year, then never again up to today...
 

·
Registered
2018 Q50 AWD Red Sport
Joined
·
6,448 Posts
Sounds like a loose wiring harness connector or an electrical short that is showing itself when a lateral G-force is being applied. The Display Control Unit controls the navigation display and Bluetooth. Might be where the problem lies but with no DTCs, it's hard to say.
 

·
Registered
Joined
·
65 Posts
Ive actually had this with my 20q50rs as well. It only is an issue when I am using android auto, so im guessing it is directly related to how the unit reads the signal from the phone and the software for your screen mirroring. I highly doubt it would be a wiring issue as my vehicle has only 600 miles, and the issue is mainly connected to having the phone directly connected, but I will continue to monitor.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
Ive actually had this with my 20q50rs as well. It only is an issue when I am using android auto, so im guessing it is directly related to how the unit reads the signal from the phone and the software for your screen mirroring. I highly doubt it would be a wiring issue as my vehicle has only 600 miles, and the issue is mainly connected to having the phone directly connected, but I will continue to monitor.
I did not have the phone connected directly to the car since I do not have Android play. At the time the phone may have been connected for charging only. It does not happen all the time just every so often i.e. every few weeks. The car is going back March 2021 so as long as it does not interfere with the rest of the car's electronics, I'm not going to worry about it any more.
 

·
Registered
Joined
·
6 Posts
Hello all. I have a 2017 q60 premium. This rebooting while driving happened a few times to me also. It wasn't all day everyday, but I was able to record it a few times and sent it to the dealership. However, Infiniti replaced the unit, as my car is still under warranty. The guy in service said he'd seen this issue before too.
 

·
Registered
Joined
·
442 Posts
I just got my DCU replaced because of same issues but not from sharp right turns. Just normal driving on highway and its always resetting especially in winter time. The day after I picked up my car from it being replaced, on drive home, still resetting LOL. so...
 
1 - 12 of 12 Posts
Top