Infiniti Q50 Forum banner
1 - 11 of 11 Posts

·
Registered
2018 Q50rs Mishimoto HE, JB4, AMS Intakes, Hall Built 3” LDPs
Joined
·
14 Posts
Discussion Starter · #1 ·
Hi guys, I am pulling my hair out, I’m running Map 0 on the JB4 (stock boost) currently because I’m in Cali and can only get 91 octane. If I go up to Map 1 I seem to get bad pinging even with a bottle of Lucas octane booster in the tank. I just looked at my logs because the car feels a bit sluggish and from what I can see even on stock boost the timing seems to be pulled down to 0 on acceleration. This is all on 91 octane with a full bottle of octane booster????
Rectangle Slope Sky Font Line
 

·
Registered
2018 Q50rs Mishimoto HE, JB4, AMS Intakes, Hall Built 3” LDPs
Joined
·
14 Posts
Discussion Starter · #5 ·
It’s hard to say when the problem started, the performance seems to be up and down sporadically based on my butt dyno. Sometimes it feels fast and breaks the tires loose a bit on acceleration in first, sometimes it feels a bit sluggish. I just installed the JB4 a couple weeks ago so I could see some logs and figure out what it going on. Sure enough it caught what I expected to see with the timing. The fuel is the same fuel I’ve been using for quite a while. Here’s another thing, I had a jb1 before getting the JB4, I would run map 1 on 91 with the same octane booster and never heard/felt the pinging/detonation, then I got the JB4, now even if I try to run +2 psi on map 6 it pings like crazy even rolling into 1/2 throttle once boost kicks in.
As far as ethanol changes in California fuel I haven’t heard anything around here.
 

·
Registered
2018 Q50rs Mishimoto HE, JB4, AMS Intakes, Hall Built 3” LDPs
Joined
·
14 Posts
Discussion Starter · #10 ·
That's the thing, it doesn't bog or run rough at stock boost it just feels really flat as far as acceleration. Also, no DTC's present or in history for whoever asked that too.
 

·
Registered
2018 Q50rs Mishimoto HE, JB4, AMS Intakes, Hall Built 3” LDPs
Joined
·
14 Posts
Discussion Starter · #15 ·
I haven't contacted them because unfortunately it appears you have to email them, no phone number to call. It's kinda hard to explain in an email.
 

·
Registered
2018 Q50rs Mishimoto HE, JB4, AMS Intakes, Hall Built 3” LDPs
Joined
·
14 Posts
Discussion Starter · #17 ·
Yea I have a Snap-ON Titan unit that I try to monitor timing on also, I own a shop so we have some resources to work with. It's weird though because today I ran Map 0 and Map 8 and now the timing seems to be normal between 5-9 degrees. I'm wondering if when I try to run map 1 and it pings bad, that sets something in the PCM for that whole drive cycle to retard timing, so even when I switch back to Map 0 on that drive cycle it still retards the timing with the lower boost???
 

·
Registered
2018 Q50rs Mishimoto HE, JB4, AMS Intakes, Hall Built 3” LDPs
Joined
·
14 Posts
Discussion Starter · #22 ·
So from what I'm gathering, it appears that the Arco station I've been going to for 91 must be off on their octane ratings. I have some race 100 unleaded I'll have to try.
 

·
Registered
2018 Q50rs Mishimoto HE, JB4, AMS Intakes, Hall Built 3” LDPs
Joined
·
14 Posts
Discussion Starter · #24 ·
Thanks everyone for all of the input! I'll update when I run this crappy fuel out and fill up with some different stuff.
 
1 - 11 of 11 Posts
Top