Infiniti Q50 Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Hi My ABS light and traction light have both come on, the mechanic which fixes my car for me put the diagnostics device on it and it showed Rear Sensor had a issue, the error codes where cleared, light went off but only for a little while then it came back on. Now the issue I am running up against is where can i get a parts manual for this car and 2nd thing would be where can i get spares for the car possible ABS speed sensor and the wheel bearing with the integrated ABS sensor any ideas any one, Spares possible in the UK as infinti have cease selling this Car in Europe been having issue trying to get a service kit for the Gearbox for weeks now. car again is a 2015 2.2.L Diesel Automatic. Any help to try and resolve this would be great.
 

·
Registered
Joined
·
3,874 Posts
You can look up the part number at any one of the Infiniti on-line parts depots. It is just shy of US $300.00. Then there would be shipping costs to the UK.

It is likely the sensor because that is a common problem. You may also want to check it for debris and its relation to the ring gear. Occasionally that will cause a fault.

I don't know if the part would be available at a Nissan dealer. Look up the number and give it a try. I have a Nissan dealer that is walking distance from my home that I have ordered parts from twice. I go there because I know some of the people there and am given a slight discount comparable to the on-line sellers. Next day delivery and no shipping charges. Daily deliveries from Chicago depot.
 
  • Like
Reactions: mrdata123

·
Registered
Joined
·
21 Posts
Discussion Starter · #3 ·
I wished i had done my homework on this car before i purchased it had issue since June with another issue, trying to get map updates has prove nil on impossible, thank you for responding i have found a parts manual for the European version of the car today, been emailing someone in Dubai about parts, have tried local Nissan Dealership waiting for word back spent 2 days trying to figure out if can get the sensors in this country or not, so far answer is No then also found out that i can get 7 different Rear Wheel Hub Kits but no idea which one i would buy if i needed to some have integrated ABS sensors, some have integrated magnetic rings some don't mention them at all, think my head is going to explode. Joys of owning a Q50 i suppose Thank you again for the response.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #4 ·
You can look up the part number at any one of the Infiniti on-line parts depots. It is just shy of US $300.00. Then there would be shipping costs to the UK.

It is likely the sensor because that is a common problem. You may also want to check it for debris and its relation to the ring gear. Occasionally that will cause a fault.

I don't know if the part would be available at a Nissan dealer. Look up the number and give it a try. I have a Nissan dealer that is walking distance from my home that I have ordered parts from twice. I go there because I know some of the people there and am given a slight discount comparable to the on-line sellers. Next day delivery and no shipping charges. Daily deliveries from Chicago depot.
sorry I meant to reply on your response D.oooh Stress out. Thanks again see rant below...
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #5 ·
Just a wee update on this, it appears my Abs/antiskid Pump has a issue and is going to have to be swapped out next week also i have had my Transmission serviced as well real money pit this car is turning out to be..
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #11 ·
Work has sort of come first and my plans to get the job done has been put on hold until it quiet down a little then it will get done good luck if you are planning on doing this let me know if it works out for you
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #12 ·
Work has sort of come first and my plans to get the job done has been put on hold until it quiet down a little then it will get done good luck if you are planning on doing this let me know if it works out for you
Just got a service manual for this car to see what was involved in replacing the ABS actuator/pump what a big job, specially with a replacement salvage part, looks like you have to have Consult software to read and write values from old to new but i could be wrong on this..
 

·
Super Moderator
Newport, Oregon
Joined
·
11,736 Posts
Just got a service manual for this car to see what was involved in replacing the ABS actuator/pump what a big job, specially with a replacement salvage part, looks like you have to have Consult software to read and write values from old to new but i could be wrong on this..
I believe you are correct.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #14 ·
Well the abs lights are now off after the abs pump and rear sensor swapped, but now i have another issue, when i slow down to turn into a junction is like someone has pull my handbrake on and i have no idea where this is coming from still have the issue with hesitation, that's after getting the service done on the transmission any one got any ideas where i have to throw my money at now to get this heap of nonce running right.
 

·
Registered
Joined
·
75 Posts
Well the abs lights are now off after the abs pump and rear sensor swapped, but now i have another issue, when i slow down to turn into a junction is like someone has pull my handbrake on and i have no idea where this is coming from still have the issue with hesitation, that's after getting the service done on the transmission any one got any ideas where i have to throw my money at now to get this heap of nonce running right.
Hi friend i fixed my problem by disconnecting the icc , it was made a short in all of the car systems, do you have any warning light? Because when i had my problem it felt like my car handbrake is pressed aswell
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #16 ·
Hi friend i fixed my problem by disconnecting the icc , it was made a short in all of the car systems, do you have any warning light? Because when i had my problem it felt like my car handbrake is pressed aswell
no all the warning lights have gone, now when the abs pump and the sensor where changed, it would not clear the codes/lights, car was then taken for a drive, after about 10 mins driving the Sensor started reading ok on the Diagnostics scanner, then the abs light and antiskid lights both went out, thought ok that's it done then later on when driving the car when slowing down and going into junctions from right or left hand it was like someone had pulled on the handbrake, starting to hate this car with a passion, always wanted one, got one now i want rid but stuck with it for the next few years.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #17 ·
Well the car has been off the road for nearly a month now, my garage got a auto electrician to look the car over they believe the issue is from the salvaged pump, got a replacement sent just waiting for this to be fitted and tested and hopefully get my car back . hopefully it will be ok when i do get it back, had to buy a cheap runabout to keep me on the road.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #18 ·
well replacement fitted, gearbox tested and given good health report, twice i have had the ESP light come on twice when you power car off then back on it disappears back to normal, today after the gearbox tested it was identified that odd tyres on car could be causing a issue a diameter different on front axle one 84 other 83, that would explain the balance on car at front being wrong long story short changed all 4 tyres on call to the same make size etc. can throttle values be reset as its still not right, but its better than its been can the ECU values for the throttle be reset so it re-learns the input ??.. anyone know or can help thanks in advance..
 

·
Registered
Joined
·
2 Posts
well replacement fitted, gearbox tested and given good health report, twice i have had the ESP light come on twice when you power car off then back on it disappears back to normal, today after the gearbox tested it was identified that odd tyres on car could be causing a issue a diameter different on front axle one 84 other 83, that would explain the balance on car at front being wrong long story short changed all 4 tyres on call to the same make size etc. can throttle values be reset as its still not right, but its better than its been can the ECU values for the throttle be reset so it re-learns the input ??.. anyone know or can help thanks in advance..
Hey Bro,
I hope you get it fixed. I am having the same problem with rear abs sensor. I checked it for resistance value and compared it to rear left abs sensor. I don't really know what is the resistance value should be for right rear. It will be helpful if I have the manual. Can you possibly email it to me at [email protected]
 

·
Super Moderator
Newport, Oregon
Joined
·
11,736 Posts
Hey Bro,
I hope you get it fixed. I am having the same problem with rear abs sensor. I checked it for resistance value and compared it to rear left abs sensor. I don't really know what is the resistance value should be for right rear. It will be helpful if I have the manual. Can you possibly email it to me at [email protected]
There's no resistance value listed for the sensors. If you have continuity to the ABS actuator and electric control unit and power to the sensor, then the sensor is suspect. The sensors are tested by connecting a wheel sensor tester to the sensor in question and spinning the wheel. The tester will flash on and off as the magnets on the sensor rotor pass by the sensor head. If there's no flashing, then the sensor needs to be replaced.
 
1 - 20 of 21 Posts
Top