Infiniti Q50 Forum banner
41 - 43 of 43 Posts

·
Super Moderator
Joined
·
3,740 Posts
Finished up the Dropbear Oil Pan install today. Made a trip to the dealer to get one copper crush washer. Parts guy let it go for nada (typically $0.48 each). Installed the drain plug and washer, then filled up with 6 7/8 qts of oil. Took it for a test drive - no runs, leaks, or errors.

Checked the dipstick and was just off the Full mark, so I added the last 8 oz in the bottle to make it a 7-qt fill total :cool:. I also emptied the Mishimoto OCC, which didn't have much capture in the 2k miles since my last oil & filter change.

Now looking forward to installing the Syvecs AWD Controller this weekend, and flash the ECU with a update to the base tune (from Seb) to address the sporadic DTC codes I get for Cam Advance "A" and "B" bank error, which Ecutek has published an update.
 

·
Super Moderator
Murrieta, CA, USA
Joined
·
7,703 Posts
Finished up the Dropbear Oil Pan install today. Made a trip to the dealer to get one copper crush washer. Parts guy let it go for nada (typically $0.48 each). Installed the drain plug and washer, then filled up with 6 7/8 qts of oil. Took it for a test drive - no runs, leaks, or errors.

Checked the dipstick and was just off the Full mark, so I added the last 8 oz in the bottle to make it a 7-qt fill total :cool:. I also emptied the Mishimoto OCC, which didn't have much capture in the 2k miles since my last oil & filter change.

Now looking forward to installing the Syvecs AWD Controller this weekend, and flash the ECU with a update to the base tune (from Seb) to address the sporadic DTC codes I get for Cam Advance "A" and "B" bank error, which Ecutek has published an update.
You used a magnetic drain plug, I trust? ;)

 

·
Super Moderator
Joined
·
3,740 Posts
41 - 43 of 43 Posts
Top