Infiniti Q50 Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hi guys, I currently own a 2014 Infiniti Q50 Premium with around 40k kms on it. Yesterday while I was driving, these errors popped out :

1 : AWD Error see owner manual
2 : Chassis Control System Error see owner manual

I have made some research and saw many threads talking about the same errors, but they all date back from 2013-2015.. And none really had a fix for the problem. Some says it's the ABS Sensors, some says it's because of the cold.. Which would be pretty ironic on an AWD car since it's obviously made for being winter driven..

Anyway, I have set an appointment with the dealership later this week, but I was wondering if the Chassis System is covered by the 4 years 100 kms warranty ?

Thank you !!
 

·
Registered
Joined
·
3,213 Posts
EVERYTHING is covered under the base warranty. Except of course, wear items.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
EVERYTHING is covered under the base warranty. Except of course, wear items.
Alright it's because the dealer keep telling me that if it's not under warranty I'll have to pay for their work. But my car is still covered under the base warranty so I should be fine I guess.
 

·
Registered
Joined
·
3,213 Posts
Alright it's because the dealer keep telling me that if it's not under warranty I'll have to pay for their work. But my car is still covered under the base warranty so I should be fine I guess.
God! I hate that when the dealer's service personnel start out with a negative. LOUSY attitude. They could simply say "Please bring it in and we will be happy to assess the issue". I can't imagine any scenario where that would not be covered unless you purposely tried hard to abuse it. And if they discovered that was the case THEN they could burst your bubble. LOUSY public relations.

Do you have another dealer to go to?
 
  • Like
Reactions: BigHeadClan

·
Registered
Joined
·
1 Posts
Same problem. My car has a fault rear ABS wheel speed sensor. Sadly, my warranty is gone. It costs me 130 bucks for the test and will cost 652+tax for a fix.
I'm so depressed now...
 

·
Registered
Joined
·
14 Posts
Discussion Starter #6
God! I hate that when the dealer's service personnel start out with a negative. LOUSY attitude. They could simply say "Please bring it in and we will be happy to assess the issue". I can't imagine any scenario where that would not be covered unless you purposely tried hard to abuse it. And if they discovered that was the case THEN they could burst your bubble. LOUSY public relations.

Do you have another dealer to go to?
Not really it's the only one in my region.

**** sorry to hear that MeloKing, that sucks :(
 

·
Registered
Joined
·
3,213 Posts
Same problem. My car has a fault rear ABS wheel speed sensor. Sadly, my warranty is gone. It costs me 130 bucks for the test and will cost 652+tax for a fix.
I'm so depressed now...
Yow! $652? It is not a Ferrari. Did you check with a good indie shop or even a Nissan dealer. I can't believe the part is that expansive. They should be able to diagnose and replace it in an hour so the total labor should be $130.00. They did mine under warranty while I waited.
 

·
Registered
2018 Jaguar XE, had 2017 Red Sport 400, 17 Silver Sport, 14 Hybrid and 14 Base 3.7.
Joined
·
1,599 Posts
Hi i had the same problem with my 14, its the ABS sensor they did replace it, and it is under warranty until 100,000 K.
 

·
Registered
Joined
·
67 Posts
Yow! $652? It is not a Ferrari. Did you check with a good indie shop or even a Nissan dealer. I can't believe the part is that expansive. They should be able to diagnose and replace it in an hour so the total labor should be $130.00. They did mine under warranty while I waited.
My 14 Hybrid Awd Premium had that error once. Turned off, then back on and it went away, lucky for me.
Here are prices for the sensor at infinitipartsonline:
https://www.infinitipartsonline.com/auto-parts/2014/infiniti/q50/sport-trim/3-7l-v6-gas-engine/brakes-cat/anti-lock-brakes-scat
15 479014GA0A Rear Speed Sensor ABS Sensor, LEFT W/ SPORT BRAKES $287.43
15 479004GA0A Rear Speed Sensor ABS Sensor, RIGHT W/ SPORT BRAKES $291.28
15 479004GA0A Rear Speed Sensor Q50; RIGHT $291.28
15 479014GA0A Rear Speed Sensor Q50; LEFT $287.43
 

·
Registered
Joined
·
2 Posts
I bought my 2014 Q50 used. Has 76K miles on it and the exact same error just came on my dash today. I was told my car had an extended warranty but was never given any specifics.
 

·
Registered
Joined
·
1,378 Posts
I was told my car had an extended warranty but was never given any specifics.
You bought a car and never verified what the warranty coverage is before signing?
 

·
Registered
Joined
·
1 Posts
I had the same issue. Nissan dealership charged $150 to diagnose and $450 - $600 to replace. Researched on my own, found the part for $150. It took me about 15 minutes to replace the sensor myself. I don't know how the dealership can justify the cost.
 

·
Registered
Joined
·
396 Posts
The ABS and speed sensor is one of the same correct? Is it possible that you are getting debris such as mud and snow stuck in the sensor throwing those errors? Would taking off the tyre and cleaning the sensor solve the problem? Cheaper than fishing out $800.00 for it to maybe happen again.
 

·
Registered
Joined
·
2 Posts
fixityourself

I had the same issue. Nissan dealership charged $150 to diagnose and $450 - $600 to replace. Researched on my own, found the part for $150. It took me about 15 minutes to replace the sensor myself. I don't know how the dealership can justify the cost.
Can I ask you where you purchased the part? Having the same problem, left side. Had it cleaned out but the problem persists. Doesn't seem to effect the normal driving, but the warning continues to appear. Thank you for your time!!
 

·
Registered
Joined
·
4 Posts
So what exactly Was the problem? And what was the fix?
Hi guys, I currently own a 2014 Infiniti Q50 Premium with around 40k kms on it. Yesterday while I was driving, these errors popped out :

1 : AWD Error see owner manual
2 : Chassis Control System Error see owner manual

I have made some research and saw many threads talking about the same errors, but they all date back from 2013-2015.. And none really had a fix for the problem. Some says it's the ABS Sensors, some says it's because of the cold.. Which would be pretty ironic on an AWD car since it's obviously made for being winter driven..

Anyway, I have set an appointment with the dealership later this week, but I was wondering if the Chassis System is covered by the 4 years 100 kms warranty ?

Thank you !!
 

·
Registered
Joined
·
7 Posts
Same problem. My car has a fault rear ABS wheel speed sensor. Sadly, my warranty is gone. It costs me 130 bucks for the test and will cost 652+tax for a fix.
I'm so depressed now...
How long can you drive the car with that notification though?
 

·
Registered
Joined
·
7 Posts
My 14 Hybrid Awd Premium had that error once. Turned off, then back on and it went away, lucky for me.
Here are prices for the sensor at infinitipartsonline:
https://www.infinitipartsonline.com/auto-parts/2014/infiniti/q50/sport-trim/3-7l-v6-gas-engine/brakes-cat/anti-lock-brakes-scat
15 479014GA0A Rear Speed Sensor ABS Sensor, LEFT W/ SPORT BRAKES $287.43
15 479004GA0A Rear Speed Sensor ABS Sensor, RIGHT W/ SPORT BRAKES $291.28
15 479004GA0A Rear Speed Sensor Q50; RIGHT $291.28
15 479014GA0A Rear Speed Sensor Q50; LEFT $287.43
Interesting, I got 2 new tired put on and aligned. I'm hoping that once I turn the car on tomorrow, it will reset? I drove the car home a few miles and so no difference in the notifications unfortunately.
 

·
Registered
Joined
·
4 Posts
I
Interesting, I got 2 new tired put on and aligned. I'm hoping that once I turn the car on tomorrow, it will reset? I drove the car home a few miles and so no difference in the notifications unfortunately.
Have been driving a couple weeks. NO issues besides the lights.. that part is fir rwd. Wish my awd was that cheap for rrear sensor.
 
1 - 20 of 28 Posts
Top