Infiniti Q50 Forum banner
1 - 20 of 33 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Today this awd error warning popped up on my 2015 q50 premium, has this ever happened to anyone? If so was it expensive to get it fixed?
91618
 

·
Administrator
Newport, Oregon
Joined
·
13,643 Posts
There are three AWD warnings and you have the worst one. Does it remain on after cycling the ignition?

You need to have this inspected by the dealership. You have no ABS or AWD and the car isn't safe. Without diagnostics, there's no way to say how much it could cost to repair.
 

·
Administrator
Newport, Oregon
Joined
·
13,643 Posts
I had this issue and took it to the dealership where they found that it was a speed sensor that went bad. It was replaced under warranty and haven’t had an issue since.
That's usually what causes his problem...hopefully. It could also be the AWD Control Unit or the ABS Actuator and Electric Control Unit, which are spendy.
 

·
Registered
Joined
·
110 Posts
I had the same issues a couple months back. Both Wheel Speed Sensors needed replaced. Bought them from Infiniti (came with warranty) and replaced them myself and was all about $650. Best to go get it checked as stated above, though to rule out any major issues.
 

·
Administrator
Newport, Oregon
Joined
·
13,643 Posts
I'm not completely sure but it appears to me that the AWD solenoid is integrated into the electric-controlled coupling and you have to replace the coupling if the solenoid fails.

You would have to separate the front and rear transmission cases and press the coupling off the main shaft. This is best left to professionals who know what they're doing. I wouldn't recommend DIY unless you are experienced with and have the proper tools for transmission work.
 

·
Registered
Joined
·
7 Posts
Correction awd solenoid.
Where is this located?
I took It to the dealer and they said it was a speed sensor. They wanted the 365 for the part.
It looks like 15 min worth of work. Does anyone know the part number?
I was looking at infinit parts deal they have it for $204 OEM pretty impossible to get it aftermarket
 

·
Registered
Joined
·
7 Posts
I took It to the dealer and they said it was a speed sensor. They wanted the 365 for the part.
It looks like 15 min worth of work. Does anyone know the part number?
I was looking at infinit parts deal they have it for $204 OEM pretty impossible to get it aftermarket
It was the right rear abs speed sensor, very typical I heard from the service manager
 

·
Administrator
Newport, Oregon
Joined
·
13,643 Posts
With or without sport brakes?
 

·
Registered
Joined
·
7 Posts
With or without sport brakes?
No sport brakes
I bought the part thru Infiniti parts deal 47900-4gaoa they quoted $204 and I paid and next day they charged me $85 dollars more.
I thought it was cheap but it seemed shady.
putting it on this weekend
 

·
Administrator
Newport, Oregon
Joined
·
13,643 Posts
Good luck with the repair! That does seem expensive for a wheel sensor.
 

·
Registered
Joined
·
7 Posts
Hopefully, it does not come down to luck. LOL
The dealer quoted the part at $365 with tax.
I saw them at other dealers for $265 all were oem
Doing back brakes as well at 32 k , I am second owner, It was from NYC
Front brakes were done at 18 k with rotors, he must have been hard on them for such low mileage
 

·
Registered
Joined
·
7 Posts
Hopefully, it does not come down to luck. LOL
The dealer quoted the part at $365 with tax.
I saw them at other dealers for $265 all were oem
Doing back brakes as well at 32 k , I am second owner, It was from NYC
Front brakes were done at 18 k with rotors, he must have been hard on them for such low mileage
Completed the installation of the abs speed sensor.
It took about 30 minutes,Very tight to get the wire threaded over the bar. Just an fyi the left one looks harder then the right one.
The computer reset automatically once the sensor was installed.
Back on the road.
 

·
Premium Member
Joined
·
3,327 Posts
Side note...a similar error pops up when you undo the plug in the trunk to put the car into RWD mode for tossing around or getting it on a 2wd dyno. It goes away after plugging the connector together again and starting the car.
 

·
Registered
Joined
·
12 Posts
There are three AWD warnings and you have the worst one. Does it remain on after cycling the ignition?

You need to have this inspected by the dealership. You have no ABS or AWD and the car isn't safe. Without diagnostics, there's no way to say how much it could cost to repair.
What happens if all three AWD errors popped up?
 

·
Registered
Joined
·
10 Posts
Today this awd error warning popped up on my 2015 q50 premium, has this ever happened to anyone? If so was it expensive to get it fixed? View attachment 91618
I had the same issue pop up lastnight the car drove fine but woke up this morning and went to drive it and the check engine light also popped up. Was told a couple of codes especially PO500 for the vehicle speed sensor so I ordered it and hopefully the problem goes away any other issues should I worry bout?
 

·
Administrator
Newport, Oregon
Joined
·
13,643 Posts
I had the same issue pop up lastnight the car drove fine but woke up this morning and went to drive it and the check engine light also popped up. Was told a couple of codes especially PO500 for the vehicle speed sensor so I ordered it and hopefully the problem goes away any other issues should I worry bout?
How do you know it's a wheel speed sensor and if so, is it front or rear? The part numbers are different. It could also be something else:

Font Material property Parallel Screenshot Number
 
1 - 20 of 33 Posts
Top