Infiniti Q50 Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
6,224 Posts
You'd need to bring it in and have a mechanic actual diagnose the issue, it could be a loose or damaged wire or a bad Output speed sensor.
The C1150 code is for a faulty ABS Unit however that isn't likely related to the P0720 code and probably just low brake fluid levels.
 
  • Like
Reactions: Julie84

·
Registered
Joined
·
6,224 Posts
Thank you for this. Bringing it to the mechanic tomorrow.
Any word from your mechanic? Curious to see what they said.
 
  • Like
Reactions: Julie84

·
Registered
Joined
·
2,166 Posts
Before you assume you need a new transmission, take a look at this thread.

There is even a TSB linked in that thread that says do not replace the output speed sensor, but instead replace the valve body.
 

·
Administrator
Newport, Oregon
Joined
·
15,857 Posts
You'd need to bring it in and have a mechanic actual diagnose the issue, it could be a loose or damaged wire or a bad Output speed sensor.
The C1150 code is for a faulty ABS Unit however that isn't likely related to the P0720 code and probably just low brake fluid levels.
It's C1155, not C1150. Most likely a low brake fluid level or level switch issue. The DTC does disable some of the braking functions, so it needs to be addressed.

Font Screenshot Number Parallel Rectangle
 
  • Like
Reactions: BigHeadClan

·
Registered
Joined
·
6,224 Posts
It's C1155, not C1150. Most likely a low brake fluid level or level switch issue. The DTC does disable some of the braking functions, so it needs to be addressed.

View attachment 108355
Dyslexia really doesn't do my any favors most days yeesh. Glad my recommendation still matches with low brake fluid level. XD
 

·
Registered
Joined
·
20 Posts
Is your car in any sort of limp mode? I’m not saying you have the valve body failure issue, but the speed sensor code did show along with 1 more when mine failed. My q clunked on a down shift a long while back and then it stopped going into manual mode all together and would not go beyond 3rd gear. If yours is doing this I would then say you are looking at valve body failure
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #10 ·
Is your car in any sort of limp mode? I’m not saying you have the valve body failure issue, but the speed sensor code did show along with 1 more when mine failed. My q clunked on a down shift a long while back and then it stopped going into manual mode all together and would not go beyond 3rd gear. If yours is doing this I would then say you are looking at valve body failure
Yes it is on limp mode will not go above 30 miles an hour and I cannot use manual. It is currently still in the shop.
 

·
Registered
Joined
·
2,166 Posts
Yes it is on limp mode will not go above 30 miles an hour and I cannot use manual. It is currently still in the shop.
Did you and / or your mechanic review the thread below that I shared with you above? It would seem to be very relevant to your situation.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #12 ·
Did you and / or your mechanic review the thread below that I shared with you above? It would seem to be very relevant to your situation.
Yes I sent it to him. He said he is checking this out. Keep you posted.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #14 ·
We took it to a transmission mechanic that we have worked with before on a different car. The car is still under warranty, so the shop was inspected and found legit.
 

·
Registered
Joined
·
20 Posts
If you have warranty just go to Infiniti man. They literally will fix it as good as possible. Now, I do not have faith in my local Infiniti but they do get a **** load of training and they have all possible available resources to fix it and fix it right. The dude at the transmission shop doesn’t have the same knowledge of your specific transmission and the q50 isn’t an easy car to work on. Also 12k mile warranty on their work
 
1 - 15 of 15 Posts
Top