Infiniti Q50 Forum banner

441 - 460 of 507 Posts

·
Registered
2017 AWD Q50 RS
Joined
·
10 Posts
Oh, i get the concept of burping it and all. Remember, they drove it 100 miles before they gave it back to me. I drove it 20 after that and that’s when it happened. System would have burped itself after 100 miles and I didn’t open the system between their 100 and my 20. So if that is the case, then they lied to me about driving it.
 

·
Registered
Joined
·
1,168 Posts
Technically an air pocket in the cooling system can do what you described, but given how they've acted, I wouldn't guarantee that's the issue lol.
Agree. All except the coolant smell part.
 

·
Super Moderator
Newport, Oregon
Joined
·
9,847 Posts
Yes, I have a loaner. They called me this afternoon and said the car is ready for pickup. they claimed there was an “air bubble” in the line and that’s why it appeared as if it was leaking coolant. When I asked why the engine compartment smelled like burning coolant still, they said they didn’t know. I also asked how an air bubble can displace the entire refill bottle and they didn’t know the answer to that. They insist it’s not leaking coolant anymore. I told them that if I picked it up and drove off and it was still leaking coolant that I would be really pissed. He said, “well i can’t guarantee.....”. This place is a three ring circus. picking up tomorrow and can’t wait to see how much that jug goes down after I drive off the lot.
Where's the next nearest Infiniti dealership? You may want to go there instead.
 
  • Like
Reactions: u1arunit

·
Registered
Joined
·
2,316 Posts
Discussion Starter #444
Oh, i get the concept of burping it and all. Remember, they drove it 100 miles before they gave it back to me. I drove it 20 after that and that’s when it happened. System would have burped itself after 100 miles and I didn’t open the system between their 100 and my 20. So if that is the case, then they lied to me about driving it.
It's not just burping. If an air pocket is trapped in a location where it can't burp or escape (which does happen on some engines and why they use the pressurized coolant tool), if will give the symptoms you show including pushing coolant out the overflow/cap repeatedly and leave you with low coolant and a coolant smell.
 

·
Registered
Joined
·
1,168 Posts
It's not just burping. If an air pocket is trapped in a location where it can't burp or escape (which does happen on some engines and why they use the pressurized coolant tool), if will give the symptoms you show including pushing coolant out the overflow/cap repeatedly and leave you with low coolant and a coolant smell.
That would show a traceable leak though, so unless Helen Keller is the tech they should have easily seen that.
 

·
Registered
Joined
·
2,316 Posts
Discussion Starter #446
That would show a traceable leak though, so unless Helen Keller is the tech they should have easily seen that.
Based on the technical ability of this dealership.....you may not be far off with your Helen Keller reference ;)
 

·
Registered
Joined
·
4 Posts
Hi everyone. I'm hoping someone here can help me with issues on my '19 Q50 RS that I think are related to the turbos/wastegates. A few months after getting the car back in February '19 I developed the following symptoms:
  • serious lack of acceleration from ~2k-4k rpm
  • loss of full power overall
  • hesitation upon accelerating
  • the sound of rushing air into the cabin on the passenger side
  • most recently, slight squeal at high rpm's
These issues aren't always apparent and I haven't noticed a clear pattern so far. One thing I do know, from looking at the performance app on the InTouch system, is that when I have those symptoms I'm not getting 100% fuel under WOT. I've taken the car in multiple times only to be told that they "can't reproduce the issues". The only modification I have is the JB4 that I've used on Map 1/2. Originally I thought the JB4 was causing the problems, but even after removing the unit I'm still seeing them. I'm taking the car in again tomorrow, is there anything I should have the service advisor/tech focus on or double-check to get this resolved?

I'll try to add a clip of what I'm experiencing. Thanks in advance, much appreciated.

 

·
Registered
2017 AWD Q50 RS
Joined
·
10 Posts
Picked it up on Saturday and this is where the level was when the engine is hot (yes, this is where they filled it to when they gave it back to me) and where it is now. I’ve been looking at it/taking pictures every day. Engine compartment still reeks of burning coolant. Going to try to take it to another dealer and explain the situation and see if they can do anything for me. I really almost want them to buy the car back at this point. I’ll let you know where I end up.
 

Attachments

·
Registered
Joined
·
4,996 Posts
  • Like
Reactions: u1arunit

·
Registered
Joined
·
1,861 Posts
Omg I spit out my beer reading that. XD
Labatts? Molson?

Growing up on the South side of the Peace Bridge, I went through a Labatts 50/50 phase... it was a step-up from Genesee Cream Ale.
 

·
Registered
Joined
·
4,996 Posts
Pilsner is my cheap beer and Erdinger is my go to German Beer.
 

·
Premium Member
18 RS Q50 RWD
Joined
·
42 Posts
which cooling system? I remember the porous block issue that plagued these cars a while back, good sized coolant splotches on some blocks. must have gotten hot enough to smell.
 

·
Registered
Joined
·
4 Posts
What do the jb4 logs say? You should make a separate thread instead of in here. Ask to go for a ride with a service tech and show him.
I took the jb4 off as soon as I started having issues and didn’t get to check out the logs. In any case I got to drive with a tech and even though most other times I couldn’t reproduce the issues when driving with them, this time we were able to catch it all. Turns out it is the turbos and I’m getting both replaced under warranty in about week. I’m finally relieved.
 

·
Registered
Joined
·
1,861 Posts
Turns out it is the turbos and I’m getting both replaced under warranty in about week. I’m finally relieved.
Huh... a '19 getting both turbos replaced :eek:
 

·
Premium Member
Joined
·
2,122 Posts
I took the jb4 off as soon as I started having issues and didn’t get to check out the logs. In any case I got to drive with a tech and even though most other times I couldn’t reproduce the issues when driving with them, this time we were able to catch it all. Turns out it is the turbos and I’m getting both replaced under warranty in about week. I’m finally relieved.
do you have a red sport? how much boost were you adding?

Huh... a '19 getting both turbos replaced :eek:
because racecar
 

·
Registered
Joined
·
2,316 Posts
Discussion Starter #457
I took the jb4 off as soon as I started having issues and didn’t get to check out the logs. In any case I got to drive with a tech and even though most other times I couldn’t reproduce the issues when driving with them, this time we were able to catch it all. Turns out it is the turbos and I’m getting both replaced under warranty in about week. I’m finally relieved.
Sorry to hear that. If you can make a post in the format of the first post in this thread I will add you to the list.
 

·
Registered
Joined
·
4 Posts
Sorry to hear that. If you can make a post in the format of the first post in this thread I will add you to the list.
Excuse the late reply. Repair seems to be taking longer than expected. But...

Year - 2019 Q50 RS
Miles when replaced - ~18k
One or both turbos - Both
Mods - None, aside from the JB4 I ran for about a year; Map 1/2
Boost - Running JB4 initially ~18psi, more recently stock boost.
Symptoms-
  • Hesitation when accelerating, lack of power from ~2500k-4000k rpm
  • Sound of rushing air into cabin on passenger side
  • More recently squeeling/whistling on passenger side.
  • Tech said passenger turbo bearings have failed, saw oil around both turbos. Although the amount of oil wasn't drastic he'd request for both to be replaced. :(
 

·
Super Moderator
Newport, Oregon
Joined
·
9,847 Posts
Excuse the late reply. Repair seems to be taking longer than expected. But...

Year - 2019
Miles when replaced - ~18k
One or both turbos - Both
Mods - None
Boost - Running JB4 initially ~18psi, more recently stock boost.
Symptoms-
  • Hesitation when accelerating, lack of power from ~2500k-4000k rpm
  • Sound of rushing air into cabin on passenger side
  • More recently squeeling/whistling on passenger side.
  • Tech said passenger turbo bearings have failed, saw oil around both turbos. Although the amount of oil wasn't drastic he'd request for both to be replaced. :(
2019? Yikes! Aren't those suppose to be the improved turbos?
 
  • Like
Reactions: BigHeadClan

·
Premium Member
18 RS Q50 RWD
Joined
·
42 Posts
excellent post, but just a little more if you would. the model and mods,. were you running 18psi and suddenly lost power, or was it on subsequent pulls? and was the motor dropped and turbos removed before the tech could confirm that the bearings were shot and there was some oil? trying to find out if there is a way an owner can determine bearing failure for himself. afaik we can only see the front side of the compressor wheel. thank you
 
441 - 460 of 507 Posts
Top