Infiniti Q50 Forum banner
1 - 7 of 7 Posts

·
Premium Member
Joined
·
1,569 Posts
Discussion Starter · #1 ·
So I'm finally able to get some longer drives in with my Q and I'm playing around with different settings.

Here's a few things I noticed but I'm not sure they are working the way they should. Looking for any feedback on these items:

I turned on sport mode and the steering changed to heavy/quick. I believe that is supposed to happen. I turned off my car and when I turned it back on the car was still in sport mode. Isn't the system supposed to default back to standard mode when you turn the car off?

Also, when I switched from sport to standard mode (different drive time) the steering modes stayed at heavy/quick. Not personal mode, standard. Isn't the steering mode supposed to return to standard/standard when I switch back to standard mode?

Thanks in advance.
 

·
Premium Member
Joined
·
4,882 Posts
Where did u check that the steering effort didnt change? From the intouch system menu? Cuz the ones u see there is for personal setting only! Unless u change it yourself it shouldnt change and whatever setting is input there is going to be the one applied to the personal mode!
 

·
Premium Member
Joined
·
1,569 Posts
Discussion Starter · #3 ·
Hmmm, well, when I switch to sport mode, the steering switches to heavy/quick and that is confirmed by what the manual says.

Other steering doesn't change back to std/std when I select standard mode though.

Also, when I turn the car back on it stayed in sport mode. Again, manual confirms it should return to standard.

Weird. . .

I'll triple check to see if the in-touch display doesn't change with the modes. That would be odd though, wouldn't it make sense to see what the steering setting is whenever you want? If what you are saying is true then the steering wouldn't have changed to heavy/quick on the display if my personal setting is std/std right?

I'll check it out,

Thanks!
 

·
Premium Member
Joined
·
4,882 Posts
For me the wierd part is the settings not changing when u turn the car off and turn it back on! How do u know it didnt change though? From the display @ the dash or from intouch drive mode settings? Basically all the other modes have preset settings depending on what drive mode u choose when u flick the drive mode switch by the center console! Thats why when u change settings in the intouch system, u are just adjusting your personal drive mode!

I hope i conveyed that properly! Hehe!
 

·
Premium Member
Joined
·
5,661 Posts
Well, when you're changing the steering/response settings via the Drive Mode, you should only be able to FEEL the difference between the modes. As mentioned, what you see on the Intouch display for your steering/response settings shouldn't change because those settings reflects the Personal mode specifically.

When you turn the car off and turn the car back on, I believe it should always revert back to 'Standard' mode. If you go into the menu and you look at the steering/response settings, those are settings are still only specific to your Personal mode and they won't change unless you change them yourself.
 

·
Premium Member
Joined
·
1,569 Posts
Discussion Starter · #6 ·
Ok, interesting. So the in-touch display doesn't tell you what your current steering mode is, only what you set for your 'personal' mode setting. Odd choice by Infiniti but I guess that makes sense?? Why you wouldn't be able to see what your current steering mode is and when you switch to 'personal' see what you have for that setting doesn't make much sense from a practical point of view.

So let's say that's the case, that would answer that question.

The other one, as you both point out - and as the manual states - the car should always return to the standard mode setting when you turn it on regardless of the last mode you were in when you turned the car off - must have been a glitch.

The display in the center VID between the tach and speedo was showing sport mode when I started her up. I'll test it again when I drive today but I thought that was odd considering we've all been aware of the way it 'should' work all along. Just wondering if others have seen this too.

Thanks for the feedback guys!
 

·
Premium Member
Joined
·
4,882 Posts
No prob man! I had to figure that out for myself too and it was odd @ first! Glad to have cleared that up for u! :)
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top