Infiniti Q50 Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi guys, new user here. I recently bought by second 3.7 Q50 and noticed that when I put it into Sport, Personal or Eco mode, the drivetrain doesn't actually do anything, the car is basically stuck in standard mode, it has been this way since I bought the vehicle about a month ago. I had a 2014 Q50 for 2 years before buying this one so I'm very familiar with the drive modes and how they're supposed to feel. I recently had a CEL come on for a misfire on cylinder 6 so I thought maybe the car disabled drive mode changes as a precaution? I cleared the code a couple days ago, and last night I replaced the spark plugs and installed a Takada Stage 2 CAI, left the battery disconnected for several hours, and the car runs very smooth but drive mode selector still doesn't change the vehicles performance even thought it says it does on my dash & display. Also, when the car is in ECO mode, the green indicator light by the speedometer doesn't come on either, further confirming that the car is in Standard mode. I've researched online for days and can't find anything, I even checked fuses and everything looked good, I'm at a loss.
 

·
Registered
Joined
·
2,163 Posts
Disconnect the battery for 15 minutes, then reconnect and go for a drive. Let us know how that goes.
 

·
Registered
Joined
·
2,163 Posts
That’s an odd one for sure. Imma dig into the FSM and see if I find anything about this for you.
 

·
Registered
Joined
·
223 Posts
I'm not sure it's the same but I looked for it and it brought me back to a different thread here where @Avedis53 mentioned drive mode selector being turned off is a failsafe for another part failing.
#10 and #12 are the posts it's mentioned in.
 

·
Registered
Joined
·
2,163 Posts
Do you have any DTCs?
 

·
Registered
Joined
·
2,163 Posts
Could be an issue with the chassis control module, but there should be a DTC. I’m not sure what to tell you on this one. If you have a warranty, I’d say take it in. It’s probably gonna take a consult tool to figure this one out. Otherwise, you’ll have a whole lot of wiring to check for continuity.
 

·
Registered
Joined
·
223 Posts
No DTC's at the moment, no pending codes either. I had a DTC for a misfire before but I solved the issue and cleared all codes when I disconnected the battery
I agree with Skyline your best bet may be to bring it in and let Infiniti diagnose it. Without any codes there’s not much anyone can really help with besides guessing sadly.
 

·
Registered
2014 Q50 Sport Deluxe technology pkg takeda stage 2 intake custom axel-back 3inch resonated exhaust
Joined
·
772 Posts
On my car,,the Das let's you know the mode has indeed changed "can feel tremendous difference between standard/sport/personal steering feel -also while driving say 40 mph, change to sport causes immediate gearing change letting me know that something definitely has changed,,while driving you feel absolutely no change while switching modes?
 
1 - 10 of 10 Posts
Top