Infiniti Q50 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
what’s up guys i have a 2020 q50 awd…. I’ve done some mods like intake, full exhaust, down pipes, bov’s and a jb4 . my problem is after driving for bout an hour it goes into limp mode …. rarely will throw a p34a9 code ….. any ideas on where to start i was thinking cam shaft sensor?
 

·
Registered
Joined
·
1,581 Posts
If that’s the only code, then it looks like your right. Check the connection to make sure it’s tight. But on a 2020, I’d just take her in. It’ll be under warranty and might even have a TSB associated with it. Looks like there’s a TSB for it on a few other models.
 

·
Administrator
Newport, Oregon
Joined
·
15,858 Posts
what’s up guys i have a 2020 q50 awd…. I’ve done some mods like intake, full exhaust, down pipes, bov’s and a jb4 . my problem is after driving for bout an hour it goes into limp mode …. rarely will throw a p34a9 code ….. any ideas on where to start i was thinking cam shaft sensor?

Font Screenshot Parallel Number Rectangle

I'd guess that the temperature sensor in the bank 2 (passenger side) IVT control actuator may be faulty, and the actuator may need to be replaced barring any harness/wiring problems.
 
  • Like
Reactions: BigHeadClan

·
Registered
Joined
·
6,224 Posts
As said may need to take it in to get looked at, would strongly recommend an after-market heat exchanger however (you didn't list one) the stock units are laughably small.
 
1 - 5 of 5 Posts
Top