Infiniti Q50 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1
If anyone having vibrations especially between 70-85 mph and feeling mostly from seats and floor, solution is rear wheel hubs.

I have been dealing this vibrations for a long time. I’ve read some people changed their q50’s rear hubs and it fixed vibration issue.

Wheel hubs seemed to be fine, there was no noise or any play. Even mechanic who replaced them told me hubs were fine. But not.


I recommend buying aftermarket hubs. I bought them from rockauto.com
Fronts were $75 each, rear ones were $95 each. Brand name Timken, one of the best hub bearing manufacturer.

After hub change my ride is so smooth. When I was going over 70 mph without checking speed i could tell I am over 70 mph because of vibrations. And now I did same thing when I check speedometer it was 95 I was still waiting for vibrations 😁

Finally after 80k miles chasing solution, now i am done 😂
 

·
Registered
Joined
·
537 Posts
Interesting. What year and trim do you own?
 

·
Registered
Joined
·
1,331 Posts
If anyone having vibrations especially between 70-85 mph and feeling mostly from seats and floor, solution is rear wheel hubs.

I have been dealing this vibrations for a long time. I’ve read some people changed their q50’s rear hubs and it fixed vibration issue.

Wheel hubs seemed to be fine, there was no noise or any play. Even mechanic who replaced them told me hubs were fine. But not.


I recommend buying aftermarket hubs. I bought them from rockauto.com
Fronts were $75 each, rear ones were $95 each. Brand name Timken, one of the best hub bearing manufacturer.

After hub change my ride is so smooth. When I was going over 70 mph without checking speed i could tell I am over 70 mph because of vibrations. And now I did same thing when I check speedometer it was 95 I was still waiting for vibrations 😁

Finally after 80k miles chasing solution, now i am done 😂
Thanks for posting a follow-up and sharing what solved the problem!
 

·
Premium Member
2018 Q50 Red Sport 400 AWD
Joined
·
3,305 Posts
Yes, thanks for taking the time to post resolution for those who might experience this problem in the future. Most people don't take the time to be helpful to others.
 

·
Registered
Joined
·
3,065 Posts
Yes, thanks for taking the time to post resolution for those who might experience this problem in the future. Most people don't take the time to be helpful to others.
Only if people would use the search function first.

That why we are on this forum 😎👍
yep, to remind them about the search feature.
 
1 - 8 of 8 Posts
Top