Infiniti Q50 Forum banner

241 - 260 of 318 Posts

·
Super Moderator
Newport, Oregon
Joined
·
8,994 Posts
I received the replacement harness and still the same problem. The A/F sensor male connector will not lock onto the harness female connector no matter how much pressure I apply. The harness female connector has a gasket at the rear that the male connector is suppose to pass over in order to seal moisture from the connection. The A/F sensor connector will not move past the gasket at all so while it will make a connection and no MIL will appear, one good bump could cause the connector to separate and here come the DTCs. I'll reach out to the seller again and see what's next. This is getting ridiculous.
 

·
Super Moderator
Newport, Oregon
Joined
·
8,994 Posts
The seller got back to me immediately and said:

"I'll send you a replacement. Seems like you got one of the connectors that is is just a hair off. The new batch of connectors they sent me had some mixed in there that are like 99% correct but just enough off that they won't fully click. I've identified the issue now. I know it's a pain but please send that one back with the 3 stamps again. I will refund you the difference for the 2 you have sent back to me. I'll send your replacement out tomorrow. You were the first to have the issue so it was just bad timing. Good news is I've identified it so there shouldn't be any issues going forward. Thanks and sorry for the hassle."

I guess being first isn't necessarily a good thing. At least the seller is doing what he can to resolve the problem. Back to one harness and one Posi-Tap until then.
 

·
Super Moderator
2017 Q50 Red Sport 400 RWD
Joined
·
3,851 Posts
I received the replacement harness and still the same problem. The A/F sensor male connector will not lock onto the harness female connector no matter how much pressure I apply. The harness female connector has a gasket at the rear that the male connector is suppose to pass over in order to seal moisture from the connection. The A/F sensor connector will not move past the gasket at all so while it will make a connection and no MIL will appear, one good bump could cause the connector to separate and here come the DTCs. I'll reach out to the seller again and see what's next. This is getting ridiculous.
This is consistent with your post # 239. Seller told you he discovered the problem right after he sent you your replacement so your replacement could be from the bad batch again. But that, if it is bad, he now knows what to send you. Pain in the tushy but, like you said, it's nice that he responds fast and does his best to resolve.

Remind me, your PS went on just fine, it's the DS you're fighting with?
 

·
Super Moderator
Newport, Oregon
Joined
·
8,994 Posts
This is consistent with your post # 239. Seller told you he discovered the problem right after he sent you your replacement so your replacement could be from the bad batch again. But that, if it is bad, he now knows what to send you. Pain in the tushy but, like you said, it's nice that he responds fast and does his best to resolve.

Remind me, your PS went on just fine, it's the DS you're fighting with?
DS side. No problem with the PS. It's not like I can't use the fuel wires as I left the Posi-Tap on until I checked the harness for fit. I'm 100% operational so it's no big thing. It's a subtle defect in the connector that isn't visible so it's no fault of the seller and he's doing everything he can to rectify the problem.
 
  • Like
Reactions: ptatohed

·
Super Moderator
2017 Q50 Red Sport 400 RWD
Joined
·
3,851 Posts
ptatohed, great job on the write-up. Could you also make a pic of DS connector.
Also, would be nice if the EBay harness went all the way to JB4. I've already reached out to the seller.

cherno, as promised, here are the DS pics you asked for. Hope it helps. Let me know if you have any questions.


93320




93321
 

·
Registered
Joined
·
83 Posts
I sent the EBAY seller a note a couple of days ago telling him that he has a good niche with these JB4 harnesses and with just a little awareness on these types of forums, he could drum up some good business. Smart dude to read the threads and get with each of you and make it right. These threads live on forever and each new reader will either seek out his products or avoid them based on the outcomes.
 

·
Super Moderator
2017 Q50 Red Sport 400 RWD
Joined
·
3,851 Posts
I sent the EBAY seller a note a couple of days ago telling him that he has a good niche with these JB4 harnesses and with just a little awareness on these types of forums, he could drum up some good business. Smart dude to read the threads and get with each of you and make it right. These threads live on forever and each new reader will either seek out his products or avoid them based on the outcomes.
I was impressed he is following this thread, if a bit creepy, lol. ;) I stuck my two bad ones in an envelope last night and stamped it up. Will drop off at the PO today at lunch.
 

·
Super Moderator
Newport, Oregon
Joined
·
8,994 Posts
The seller has already refunded $5 to me for the postage stamps and the latest harness is suppose to ship out today.
 

·
Super Moderator
2017 Q50 Red Sport 400 RWD
Joined
·
3,851 Posts
Nice. I never know how many stamps to put on a slightly thicker and slightly heavier small envelope. I stuck on 6 stamps for the two adapters. I hope it goes. He did say he'd refund $3.

Pet peeve: People that pronounce 'envelope' as 'onvelope'.
 

·
Super Moderator
2017 Q50 Red Sport 400 RWD
Joined
·
3,851 Posts
Awesome, thanks. Any noticeable improvements while driving? BTW, what gas do you use?
FWs not hooked up yet, lol. Just the adapters! I only have 91 octane here.
 

·
Super Moderator
Newport, Oregon
Joined
·
8,994 Posts
I don't have a lot of driving time with the fuel wires yet and added them after the EWG wires so it's difficult to say what additional impact they are having without looking at some data logs. EWG wires on the other hand do make a noticeable improvement in the turbo response and acceleration hits harder than before. Based on my limited experience so far, EWG wires > fuel wires.
 

·
Registered
Joined
·
63 Posts
Avedis53, completely agree that EWG wires made a huge deal of improvement. Trying to see if getting FW is worth the hassle. I'm running on 93, and have read conflicting comments, specifically from Boost In Motion. Just looking for opinions from other forum members. And Ebay seller said he would look into designing a FW harness that plugs directly into jb4.

Otherwise, would probably target Helmholtz exhaust. Any good deals on it after di_parts departure? Unfortunately, cannot do much with exhausts in MA.
 

·
Registered
Joined
·
31 Posts
Im also waiting on owner’s input for fw upgrade (from both avedis & ptatohed)

as for helmholtz, i had it before cbe, sold it after 500 miles , the drone at 2k-3k rpm was piercing my ears, it sounds nice under wot but local drive is a pain, its 10times louder in reality than youtube vid, just my suggestion for you.
 

·
Super Moderator
2017 Q50 Red Sport 400 RWD
Joined
·
3,851 Posts
Avedis53, completely agree that EWG wires made a huge deal of improvement. Trying to see if getting FW is worth the hassle. I'm running on 93, and have read conflicting comments, specifically from Boost In Motion. Just looking for opinions from other forum members. And Ebay seller said he would look into designing a FW harness that plugs directly into jb4.

Otherwise, would probably target Helmholtz exhaust. Any good deals on it after di_parts departure? Unfortunately, cannot do much with exhausts in MA.
Curious, what did Boost in Motion say about the FWs?
 

·
Registered
Joined
·
83 Posts
This is the guy that changes his oil on a public sidewalk! If you have the built in fuel wires, hook them up - it's very easy and per Burger Tuning, they have benefit on all types of fuel. If you have to go out and buy them, install them in the JB4, and hook them up to the car, the benefits may not outweigh the effort. If you are doing the EWG wires anyway where you have to access the guts of the JB4, I would just go ahead and do fuel wires at that time as well.

After hooking mine up, the most significant difference is in the AFR at high RPMs. Mine would dip into High 10's to low 11's before the fuel wires but now holds at low 12's through redline. It does not seem to have had any adverse impact on timing.
 

·
Super Moderator
Newport, Oregon
Joined
·
8,994 Posts
After hooking mine up, the most significant difference is in the AFR at high RPMs. Mine would dip into High 10's to low 11's before the fuel wires but now holds at low 12's through redline. It does not seem to have had any adverse impact on timing.
This is my understanding also about the function of the fuel wires, that they correct AFR at higher RPMs to achieve more power by leaning out fuel at the top end.
 

·
Registered
Joined
·
31 Posts
hi terry

i have had jb4 for more than half year now and this is my first ever log after installed ewg wires today, Private file

i did a 20min test drive so the file size is bigger than allowed, does the log look okay? im no expert and not sure what i should be looking for, i think my afr is running too lean?

q50 rs, 93 octane, map1

thanks

---------------------

so i posted that on n54tech a week ago hoping terry can reply but it seems he isn't active on that thread no more, the only thing i can understand from the log is my afr is on high 14's (which i dont know if its good or bad), what happens if i add fw ?
 

·
Super Moderator
Newport, Oregon
Joined
·
8,994 Posts
I know some here prefer .csv files but I'm more of a visual person and prefer the graphs instead. Makes it easier for me to see what's going on.
 
241 - 260 of 318 Posts
Top