Infiniti Q50 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I just bought a Q50 RS400, I was reading the manual and noticed it saying changing spark plugs at 45k miles, anyone thing this is too early to change them?
 

·
Premium Member
Joined
·
2,026 Posts
These are the pages from the manual for my 2018 RS. I see every 105,000 miles unless gap is wider than spec (Note 7). I probably wouldn't leave them in there that long for fear they will seize to the head and pull the threads out.

And with manufacturer recommended service intervals (NOT dealer recommended intervals as they quite often differ), you should never exceed them if you want to keep your warranty valid.

89820



89821
 

·
Registered
Joined
·
3,729 Posts
Nothing really to add to Pillboy's statement always go with the SM maintenance period, it also helps if you include your model year in future posts
when asking for help.

We never really know when Infiniti decides to update it's documentation or makes small changes between model years.
 

·
Registered
Joined
·
1,025 Posts
I just bought a Q50 RS400, I was reading the manual and noticed it saying changing spark plugs at 45k miles, anyone thing this is too early to change them?
Are you sure you are reading the right manual? Where did you see 45k listed for the spark plugs?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
These are the pages from the manual for my 2018 RS. I see every 105,000 miles unless gap is wider than spec (Note 7). I probably wouldn't leave them in there that long for fear they will seize to the head and pull the threads out.

And with manufacturer recommended service intervals (NOT dealer recommended intervals as they quite often differ), you should never exceed them if you want to keep your warranty valid.

View attachment 89820


View attachment 89821
sorry I’m new to this, I have a 2017 Red Sport, yes the picture above is what my manual had but if you keep going further you will see this
 

Attachments

·
Registered
Joined
·
2,522 Posts
sorry I’m new to this, I have a 2017 Red Sport, yes the picture above is what my manual had but if you keep going further you will see this
You said you had an RS 400. The page you have posted is for the 2.0 engine. There's your problem.
 
1 - 7 of 7 Posts
Top