Infiniti Q50 Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Has anyone else seen this message on their nav screen?

Loading map...If the problem persists, please confirm the map SD card is inserted correctly.

I got this message, the screen went black, nav did not work. I tired a soft reboot and nothing happened I alos turned off the ignition and restarted the car but the screen was still black.
 

·
Registered
Joined
·
309 Posts
It sounds like the SD card might have popped out of the port.

I would start by opening the center console, remove and re-install the SD card in the front portion of the center box.
 

·
Registered
Joined
·
46 Posts
Has anyone else seen this message on their nav screen?

Loading map...If the problem persists, please confirm the map SD card is inserted correctly.

I got this message, the screen went black, nav did not work. I tired a soft reboot and nothing happened I alos turned off the ignition and restarted the car but the screen was still black.
Yeah I had that for the first time today! The card wasn't out because that was the first thing I checked. A reboot didn't help, but it worked after turning the car off.
 

·
Registered
Joined
·
395 Posts
I often get this message. Think it may be a bad card reader or bad SD card. Sometimes I can reboot and it works again. Other times, I have to turn off the car and start again.

Tonight, turning off my phone bluetooth and rebooting worked.
 

·
Registered
Joined
·
2 Posts
I had the same problem for the first time today. Pardon my ignorance, but how do I open the front panel to check the card?
 

·
Premium Member
Joined
·
4,882 Posts
I had the same problem for the first time today. Pardon my ignorance, but how do I open the front panel to check the card?
You dont open the front panel! The SD card for the maps is in your center console/arm rest! Hope that helps! :)
 

·
Registered
Joined
·
1,537 Posts
This happened to me tonight and when I was out of town and really needed the GPS to help me to navigate the area. This happened in the middle of driving.
I have latest InTouch *.646 but tried so many things like rebooting the system, check the SD card connection, restarted the car but none of them worked.
Went through with the Infiniti Connection and they transfered me to dealer to diagnose the problem then they decided to bring the car in to dealer.
However, after parking the car for 2 hours and came back from dinner, everything worked again.

Is this still happening on *.646 to anyone recently? I was just not happy because I was relying on it while driving then suddenly it went out (just the message). Also I noticed, my bluetooth music streaming stopped working and the bottom screen froze too.
 

·
Registered
Joined
·
395 Posts
I never had the nav unit stop while driving. All my symptoms were observed at startup.

Recently, I got a new nav board under warranty. This replacement did not fix my issues. Then, my dealer replaced my usb drive under warranty. This second replacement fixed all my intouch/nav issues and justify pcb relpacement.

You may have had a one time glitch. I suggest bringing your Q50 to your dealer so they can check the diagnostic screens and record the last error. If you know how, you can access the diagnostic screens yourself and take pics of the screen to show your dealer. This latter method is what I did to help my dealer promote my issues to the regional tech.
 

·
Registered
Joined
·
1,537 Posts
I figured out the cause of the problem.
I had two days road trip over 1000 miles and having to stop here and there, I really rely on the GPS. Yes I could use the phone for map but it is not very safe to rely on it especially in the city driving.

Anyway, this morning I figured out the problem. It turns out that my friend's samsung note phone crashed the system when trying to charge the phone via the USB. However, this only happens when you have the phone charged and the machine gets started.
However, the workaround to this is to have the phone charged after 2-3 min the system up. It was fine today but not very convenient when I had to stop here and there and start the engine with the phone plugged in.
 

·
Registered
Joined
·
395 Posts
Anyway, this morning I figured out the problem. It turns out that my friend's samsung note phone crashed the system when trying to charge the phone via the USB.
Which NOTE. Note2 or 3? And what OS version? 4.4.3?

The reason I ask is that Android 4.4.3 is causing other issues with intouch. I am suspecting this is one reason for the delayed intouch update.
 

·
Registered
Joined
·
1,537 Posts
Which NOTE. Note2 or 3? And what OS version? 4.4.3?

The reason I ask is that Android 4.4.3 is causing other issues with intouch. I am suspecting this is one reason for the delayed intouch update.
I am not sure which one but she purchased it last year. I don't think Infiniti will hold the release just for this case. It is fine on other androids.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top