Infiniti Q50 Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Purchased my Q50 Premium Black Obsedian in January. This is my first Infiniti after driving Acura's, Mercedes, Nissan's and Mazda's over the last 35 years. I like the way the car looks and drives, but I'm experiencing problems with the navigation system not loading at least half of the time I start it. Have had it into the dealership three times and while they have been very nice, they have not been able to fix it. They are talking to the factory to try to figure it out, but repeated trips to the dealership without a solution is very frustrating. The I Touch app is also not available/working so that is a disappointment. I have never experinced these type of problems with the other Japaneze cars I have owned so I am wondering it I made a mistake changing brands. Hopefully, this will get taken care of, but right now I'm not a totally satisfied customer. :(
 

·
Registered
Joined
·
194 Posts
First, Welcome.

Second, The Navigation issue, definitely not normal, you have a defective unit I think, just pure bad luck.

Third, The Intouch App, well, that's another complete story, so just look for the threads on the InTouch sub-forum and you will get a better idea, but in a summary, no, it's not available yet, even after saying that was going to be available on Late Fall 2013.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top