Infiniti Q50 Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter · #1 ·
Good afternoon all, was just curious if anyone else has noticed any sort of issues when braking at higher speeds. I drive a base model with AWD and have noticed what almost feels like warped rotors even though I am almost positive that it's not. Feels almost like a pulsating and feels like it's only coming from the rear brakes. There is no vibration or steering wheel shake coming from the front end whatsoever. This isn't a result of repetitive heavy braking in short periods of time nor am I experiencing any pedal fade. Seems to me like it could simply be the rear brakes not being adequate for a car of this weight traveling at high speeds but I don't want to be so quick to jump to that conclusion. Any input would be appreciated.
 

·
Premium Member
Joined
·
1,493 Posts
You know...I have a Sport Model and I recently started feeling the same thing with mine. Whenever I press the brakes at high speeds I get a pulsating feeling in the brake pedal but no vibration from the steering wheel (no vibration may be due to the DAS though for me, not sure). I was assuming that the rotors may be slightly warped. I was going to take mine in to the dealer next week for them to look at it and do the "recall" update while its there.

I wonder if anyone else is experiencing the same thing now.
 

·
Premium Member
Joined
·
2,672 Posts
I just noticed from your signatures that you both have Stillen roof spoilers and Welcome lighting. I suspect that's the cause of the problem.

Seriously though, this is the first I've heard of anything like this. I'd ask dealer to check it out.
 

·
Registered
Joined
·
4,279 Posts
I've noticed the same thing, but not all the time. I thought the exact same thing that they could have warped a little. This concerns me.
 

·
Registered
Joined
·
4,279 Posts
Wow.. if you warped the sport rotors. :eek:

I thought they had a good reputation of being able to take a thrashing and never fade (or warp).
Seeing other people on here noticing the same thing, I don't think it's warping. After all, it took my about 3 years to warp the ones in my G37S and I drove that car a fair amount harder and not nearly as smartly than this one. I was 26 back then versus 32 now. Jeez, now that I think about it I used to redline that car every day for probably the first 3 years I had it too. It sure held up well.
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #7 ·
Seeing other people on here noticing the same thing, I don't think it's warping. After all, it took my about 3 years to warp the ones in my G37S and I drove that car a fair amount harder and not nearly as smartly than this one. I was 26 back then versus 32 now. Jeez, now that I think about it I used to redline that car every day for probably the first 3 years I had it too. It sure held up well.
I agree with this 100%. I've warped plenty of rotors from driving very hard in BMW's and porsche's and I've never felt a feeling like this in regards to brakes, and knowing what it takes to warp a rotor or rotors and knowing I haven't done anything which warrants them warping is what really has me concerned that it's a more serious issue. The fact that it's not a consistent thing but rather a very random and spontaneous thing is making my head spin.
 

·
Premium Member
Joined
·
1,493 Posts
I agree with this 100%. I've warped plenty of rotors from driving very hard in BMW's and porsche's and I've never felt a feeling like this in regards to brakes, and knowing what it takes to warp a rotor or rotors and knowing I haven't done anything which warrants them warping is what really has me concerned that it's a more serious issue. The fact that it's not a consistent thing but rather a very random and spontaneous thing is making my head spin.
Same here. I've warped the rotors on my TL enough times in the past. I haven't driven my Q aggressive like I used to with the TL. The consistency also bothers me. I'll probably be taking my car in next week for them to look at it.
 

·
Premium Member
Joined
·
1,493 Posts
I just noticed from your signatures that you both have Stillen roof spoilers and Welcome lighting. I suspect that's the cause of the problem.
Its from that extra downforce from the STILLEN spoiler and the weight of the Welcome Lighting!. :D
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #11 ·
Before I started this thread I made the assumption that if anyone else was experiencing the same thing that it would have been on the non S cars, hearing that it's been an issue for some with the S models is a real eyebrow raiser.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top