Infiniti Q50 Forum banner
161 - 180 of 212 Posts

·
Registered
2018 Q50S [RWD]
Joined
·
189 Posts

·
Registered
2017 Q50S
Joined
·
485 Posts
  • Like
Reactions: Geraldomi

·
Registered
2017 Q50S
Joined
·
485 Posts
Ahh, that makes more sense. Still a great pass, knocking on 10s! I'll be adding a HPFP over the winter and maybe cut outs or mid pipe. Hopefully I can get close to your results.
Thanks, I updated my list. No that was on E60 :).
 

·
Registered
Joined
·
4,895 Posts

·
Registered
Joined
·
66 Posts
Ahh, that makes more sense. Still a great pass, knocking on 10s! I'll be adding a HPFP over the winter and maybe cut outs or mid pipe. Hopefully I can get close to your results.
This is my last run on E30 on Draggy 11/2/21.
 

Attachments

  • Like
Reactions: Blackhawk77

·
Registered
2017 Q50S
Joined
·
485 Posts
Nice! I need to get my exhaust flowing better, could only muster a high 11.3 on e30
This is my last run on E30 on Draggy 11/2/21.
 
  • Like
Reactions: Maximus400

·
Registered
2019 Q50 Signature Edition
Joined
·
956 Posts
Congrats! Isn't it a whole nother level?
Hooking with no spin is very nice.. was not used to how much the car would bounce/swim during the pull but I held onto it. Tires were at 19 psi, felt like a little trampoline at times
 

·
Registered
Joined
·
111 Posts
Question for some of you more season q50 racers. When you guys go out to the track do you RWD guys do the press in the white button above the brake pedal? When i took my RS to the 1/8 i feel like even with hitting the trac off button the car is still holding back power in 1st gear.

Any advice in what i can do? Best 60ft was a 1.98 and my et in the 1/8 was 8.34 at 86.6mph
 

·
Registered
Joined
·
4,895 Posts
Question for some of you more season q50 racers. When you guys go out to the track do you RWD guys do the press in the white button above the brake pedal? When i took my RS to the 1/8 i feel like even with hitting the trac off button the car is still holding back power in 1st gear.

Any advice in what i can do? Best 60ft was a 1.98 and my et in the 1/8 was 8.34 at 86.6mph
I never did. That "fix" is really more for doing donuts and burnouts. The problem is simply torque/throttle cur in the factory tune. You can only launch so hard assuming you're not losing traction. You can try a pedal commander which helps some, but there is still a limit.
 

·
Registered
2017 Q50S
Joined
·
485 Posts
You will need a good sticky tire in back. In my AWD I could barely crack a high 1.9 with JB4 but once tuned and some other goodies hit 1.5s on a drag radial. RWD can hit the same or even better with launch control dialed in and a good tire.
Would a full custom tune with ecutek help fix it too?
 
  • Like
Reactions: 17awdQ50P

·
Registered
Joined
·
111 Posts
You will need a good sticky tire in back. In my AWD I could barely crack a high 1.9 with JB4 but once tuned and some other goodies hit 1.5s on a drag radial. RWD can hit the same or even better with launch control dialed in and a good tire.
Went out tonight this time with JB4 on map 6 and still could only run a 8.3 (1/8 mile) and again best 60ft i could get is 1.98 and at 86mph. Just for shits and giggle i did run pass with map 1 with +4 on 93 and actually ran slower 8.4 at 85mph?

ive seen supposedly stock RS run 8.2-8.1 and are RWD. Only second time out but dont know what i can be doing differently or better
 
161 - 180 of 212 Posts
Top