Infiniti Q50 Forum banner
1 - 20 of 63 Posts

·
Super Moderator
Joined
·
3,250 Posts
Discussion Starter · #1 ·

·
Premium Member
Joined
·
508 Posts
How do they claim 10% better acceleration with this?
My understanding is that it just modifies the Throttle position sensor to make it feel more responsive, it’s not going to improve actual times.
For those of us that are tuned, tuners can do this too as I worked with AMS to get my throttle feel exactly as I wanted it.

Am I missing something?
 
  • Like
Reactions: SocaliridiumQ50RS

·
Administrator
Newport, Oregon
Joined
·
14,286 Posts
I just ordered the HIKE IT-X9 but before I did, I emailed HIKE IT beforehand and asked about compatibility with FEB and ICC on the Q50. They replied:

"Our controller functions with Infiniti Q50 with Forward Emergency Braking and Intelligent Cruise Control."
 
  • Like
Reactions: Jibricb

·
Super Moderator
Joined
·
3,250 Posts
Discussion Starter · #4 ·
How do they claim 10% better acceleration with this?
For the EPA drive cycle tests, the manufacturers insert a throttle tip-in delay to may the fuel economy numbers better. It is the same rationale for Auto Start/Stop features, to improve the EPA numbers. The 10% acceleration number likely is for an otherwise stock vehicle, where the increase pedal gain translates to more throttle (plate) opening command and higher injector "on" times vs stock, thus making the pedal a more aggressive gain vs tip-in delay followed by a shallower gain to achieve the 10% improvement.

My understanding is that it just modifies the Throttle position sensor to make it feel more responsive, it’s not going to improve actual times.
The Pedal Tuner increases the gain out of the pedal transducer, which translates to a higher rate change in the throttle plate and the amount of fuel command for the injectors.

For those of us that are tuned, tuners can do this too as I worked with AMS to get my throttle feel exactly as I wanted it.
Fantastic. For me, even with my Ecutek tune, I still occasionally experienced the OEM programming throttle lag when downshifting to get onto the highway. With the BMS Pedal tuner, the increased pedal gain has apparently fixed that issue. My only occasional (once every 6 months?) driveability problem is limp mode when getting into drive on a cold engine. A restart typically fixes the issue.
 
  • Like
Reactions: Q50Wolf and Q60NH

·
Super Moderator
Joined
·
3,250 Posts
Discussion Starter · #5 ·
I just ordered the HIKE IT-X9 but before I did, I emailed HIKE IT beforehand and asked about compatibility with FEB and ICC on the Q50. They replied:

"Our controller functions with Infiniti Q50 with Forward Emergency Braking and Intelligent Cruise Control."
It will be interesting to what plug is on the pigtail of the HIKE-IT for the @ptatohed Q owners with the "push back" pedal mechanism.
 

·
Super Moderator
Murrieta, CA, USA
Joined
·
7,474 Posts
I was told mine would work from Hike It and Pedal Box as well. I believe it is the darn white plug.
 
  • Like
Reactions: IridiumRS400

·
Registered
2014 3.7, 14 Hybrid S, 17 Silver sport, 17 Red Sport, now 18 Signature.
Joined
·
2,287 Posts
I just ordered the HIKE IT-X9 but before I did, I emailed HIKE IT beforehand and asked about compatibility with FEB and ICC on the Q50. They replied:

"Our controller functions with Infiniti Q50 with Forward Emergency Braking and Intelligent Cruise Control."
From what I read, it's an item that our cars can use, once you get let us know, if it does what it says.
 

·
Administrator
Newport, Oregon
Joined
·
14,286 Posts
From what I read, it's an item that our cars can use, once you get let us know, if it does what it says.
I ordered it on the 19th. It was still waiting on a shipping label as of yesterday afternoon. It's coming out of Grapevine, TX, wherever that is.
It will be interesting to what plug is on the pigtail of the HIKE-IT for the @ptatohed Q owners with the "push back" pedal mechanism.
I have the DCA system accelerator pedal assembly, so we'll see if there's a connector issue or not.
 

·
Registered
Joined
·
3,761 Posts
I ordered it on the 19th. It was still waiting on a shipping label as of yesterday afternoon. It's coming out of Grapevine, TX, wherever that is...
I got a tracking number yesterday. Due to arrive Saturday. I had contacted them after the order and processing the payment took an extra day and then they sent a couple emails and 1 had tracking.
 

·
Administrator
Newport, Oregon
Joined
·
14,286 Posts
I got a tracking number yesterday. Due to arrive Saturday. I had contacted them after the order and processing the payment took an extra day and then they sent a couple emails and 1 had tracking.
I have a tracking number from yesterday also. I'm assuming yours is coming USPS also?
 

·
Super Moderator
Murrieta, CA, USA
Joined
·
7,474 Posts
I have the DCA system accelerator pedal assembly, so we'll see if there's a connector issue or not.
I could probably tell you if you post a pic of your plug.
 

·
Administrator
Newport, Oregon
Joined
·
14,286 Posts
I could probably tell you if you post a pic of your plug.
You think I'm going to crawl under there twice? I'll wait to see the kit in my hands first. I ordered it 4 days ago and the status is "Shipping Lable Created, USPS Awaiting Item". USPS' tracking system is a complete joke.
 

·
Super Moderator
Murrieta, CA, USA
Joined
·
7,474 Posts
You think I'm going to crawl under there twice? I'll wait to see the kit in my hands first. I ordered it 4 days ago and the status is "Shipping Lable Created, USPS Awaiting Item". USPS' tracking system is a complete joke.
Taking a pic isn't bad but, yeah, reaching up high to unplug the connector will hurt your rib cage - even the next day! Good luck.
 

·
Administrator
Newport, Oregon
Joined
·
14,286 Posts
Taking a pic isn't bad but, yeah, reaching up high to unplug the connector will hurt your rib cage - even the next day! Good luck.
The last time I crawled in that cubbyhole to hardwire my dash cam power feed, I paid for it. I just hope I don't have the same connector problem, otherwise my pain will be in vain.
 

·
Super Moderator
Murrieta, CA, USA
Joined
·
7,474 Posts
The last time I crawled in that cubbyhole to hardwire my dash cam power feed, I paid for it. I just hope I don't have the same connector problem, otherwise my pain will be in vain.
I have a tip when you are ready, if needed. Fell free to call or PM.
 

·
Administrator
Newport, Oregon
Joined
·
14,286 Posts
I have a tip when you are ready, if needed. Fell free to call or PM.
Is it a secret or can you share it with others here?
 

·
Super Moderator
Murrieta, CA, USA
Joined
·
7,474 Posts
Is it a secret or can you share it with others here?
I aLREADY HAVE. Sorry, my caps were on. It's just very hard to reach up that high with two hands, one depressing the tab, and one pulling the connectors apart. I could only get one hand up there at a time. So, I used a very long screwdriver as a teeter totter lever to put pressure on the connector wires. Push down with one hand on the screwdriver handle which is out in the open, then reach up there with the other hand to press the connector release tab with your thumb nail. The connector will come apart.
 

·
Administrator
Newport, Oregon
Joined
·
14,286 Posts
I aLREADY HAVE. Sorry, my caps were on. It's just very hard to reach up that high with two hands, one depressing the tab, and one pulling the connectors apart. I could only get one hand up there at a time. So, I used a very long screwdriver as a teeter totter lever to put pressure on the connector wires. Push down with one hand on the screwdriver handle which is out in the open, then reach up there with the other hand to press the connector release tab with your thumb nail. The connector will come apart.
I'll take that under advisement if I ever get the damn thing. According to the USPS, they still haven't received it.
 
1 - 20 of 63 Posts
Top