Infiniti Q50 Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
44 Posts
It's a reprogrammed carryover from the G37, same 7 speed, new software, maybe re-valved a bit. Traditional.
So this is why the 7AT in my Q50 feels so much smoother and more refined than in my G37x Sedan. It was one of the first things I noticed when I first test-drove the Q50, the transmission felt a lot better to where I almost thought it was a brand new 7AT. The reprogramming and new software really seems to have made quite a big improvement in the overall shift quality, at least in my opinion.
 

·
Registered
Joined
·
106 Posts
So this is why the 7AT in my Q50 feels so much smoother and more refined than in my G37x Sedan. It was one of the first things I noticed when I first test-drove the Q50, the transmission felt a lot better to where I almost thought it was a brand new 7AT. The reprogramming and new software really seems to have made quite a big improvement in the overall shift quality, at least in my opinion.
I second that. Much more refined than my g37's transmission. I wonder if the new 37's have the updated transmission programming and software.
 

·
Premium Member
Joined
·
1,692 Posts
Good questions. That was one of the biggest gripes Sewell Infiniti mentioned that returning customers had. The G35 transmission was almost perfect but very aggressive. Owners coming from that to the G37 always said they preferred the old 5 speed. Infiniti updated the G37 many times and just gave up I guess. But for the Q50, they knew the transmission had to be better, and they did get it right.

In the Q50 test drives I took, the transmission wasn't worth mentioning, which (to a critical person like me) means it's perfect. Unless it's hunting gears in hill country (7th downhill, 5th uphill) then they did get it right. That's one thing I loved about my short-geared 5 speed G35. RPMs never budged at 75mph on the interstate regardless of the hill.
 

·
Registered
Joined
·
982 Posts
How do you reset the tranny? It was very smooth the first 2 months. But lately, it's been driving a little weird. Hard to explain but it's like driving on the wrong gear between 15-30 mph.
 

·
Registered
Joined
·
51 Posts
I think mine is slipping. I floored it today to cross traffic and it hesitated a lot. I then drive it around the block giving it gas and watching the RPMs. When I give it a lot of gas the RPMs go up, but the car doesn't move for a second. Anyone else have this issue?
 

·
Registered
Joined
·
1,537 Posts
I think mine is slipping. I floored it today to cross traffic and it hesitated a lot. I then drive it around the block giving it gas and watching the RPMs. When I give it a lot of gas the RPMs go up, but the car doesn't move for a second. Anyone else have this issue?
There is a thread that I created for this but mine worked after resetting ECU. However, I hate to lose my InTouch setting!
The good news, there is always Sport mode for me to switch when I need it to be agressive.
 

·
Registered
Joined
·
2 Posts
Is it the transmission?

I was on the road today and felt the car suddenly slowed down so I gave it more gas n more gas to realize the rpms went past 4 n car still won't move....does anyone have the same issue?
 

·
Registered
Joined
·
600 Posts
I was on the road today and felt the car suddenly slowed down so I gave it more gas n more gas to realize the rpms went past 4 n car still won't move....does anyone have the same issue?
This has been happening to me since i got it. Please tell me what you did to fix this problem. I and half into starting to look for new cars.
 

·
Registered
Joined
·
1 Posts
I just purchased a 2014 Q50 Premium with only 14k miles on it. I've maybe driven 850 miles since purchase, but I also just started to notice that when the car is in the "Standard" mode select, the shifting is extremely lagged and jerky. I also had a similar circumstance when trying to pass someone on the interstate... the RPM's shot up to around 5/6k and it seemed like the transmission couldn't find the right gear. Anyone think that I should have it looked at, or is this just a normal thing, and I just deal with it? Or any other suggestions???
 

·
Registered
Joined
·
1,359 Posts
I just purchased a 2014 Q50 Premium with only 14k miles on it. I've maybe driven 850 miles since purchase, but I also just started to notice that when the car is in the "Standard" mode select, the shifting is extremely lagged and jerky. I also had a similar circumstance when trying to pass someone on the interstate... the RPM's shot up to around 5/6k and it seemed like the transmission couldn't find the right gear. Anyone think that I should have it looked at, or is this just a normal thing, and I just deal with it? Or any other suggestions???
Unless Infiniti going to issue STB or recall we ( people who have imaginary problems with perfect q50) are SOL. I hope not too many of us will get hurt before that (recall) happen. If I will have even a slightest accident due to transmission idiotic programming - I will sue Infiniti and will win based on all complains on these forums (even though I am not a "I will sue your a$$" kind of person, but I AM FED UP with this crap). Same was the case with my past g37x coupe 7AT - crappy stability control/tranny programming.
 

·
Registered
Joined
·
1,359 Posts
When that happened, how do you prove it?


Sent from AutoGuide.com Free App

I always recall the scene from "Liar Liar" when he is getting his car from impound and there is a huge scratch on it.

Fletcher: You scratched my car!
Motorpool Guy: Where?
Fletcher: [indicating with his hands] Right there!
Motorpool Guy: OH... That was already there.
Fletcher: You - -LIAR! You know what I am going to do about this?
Motorpool Guy: what?
Fletcher: Nothing! Because if I take it to small claims court, it will just drain 8 hours out of my life and you probably won't show up and even if I got the judgment you'd just stiff me anyway; so what I am going to do is piss and moan like an impotent jerk, and then bend over and take it up the tailpipe!
Motorpool Guy: [tossing the keys to Fletcher] You've been here before haven't ya?
 
  • Like
Reactions: rpiotro

·
Registered
Joined
·
1,537 Posts
I would suggest the issue to be taken to Infiniti. I am not sure how much help posting the issue on the forum.
I think they will take it seriously if it involves safety and if enough people brought up to attention, they will do something about it. Recall probably?
 

·
Registered
Joined
·
18 Posts
I'm having the same problems.
Floored and RPM jumps but car doesn't accelerate.

Also having a rare chance problem.

When i was driving, and gave a little throttle and let go. My RPM was stuck AT 5-6k rpm and accelerated for 1 sec even if my foot wasoff and slowed down ...

I should. Try and reset my ECU
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top