Infiniti Q50 Forum banner

101 - 120 of 151 Posts

·
Premium Member
Joined
·
2,998 Posts
Have any of you with navigation who have used some kind of mirror mount experienced any false laser warnings?
I have Passport Max with Blendmount and no false laser warnings.
 

·
Registered
Joined
·
128 Posts
Got my 9500ix installed today with the Blendmount, very clean install and the MirrorWire from eBay for 8.95. Don't see why I should spend like 30 bucks for a similar wire. Had an ebay mirror mount for 30 on my previous car, it scratch the mirror stem like crazy. Blendmount is pricey but definitely worth it!
 

·
Registered
Joined
·
82 Posts
So following some advice here on this thread (I have a Premium Gas with Nav and Tech) I tried putting the MirrorTap leads into the Black and Gray wires... But I can't fit these in at all. I tried all four corners of each of the leads and I cant for the life of my figure out how to wedge the mirrortap leads into the molex holes.

WTF am I doing wrong?
So follow-up from my post from last month. I contacted J28 (MirrorTap) and they promptly sent me smaller leads, and those fit perfectly. Great customer services at the MirrorTap folks.

I'm installed and mounted, and so happy.
 

·
Registered
Joined
·
82 Posts
Have any of you with navigation who have used some kind of mirror mount experienced any false laser warnings?
Yep... Been getting random false laser warnings a few times since installing a month ago. This is on a ValentineOne. Positive there's no cops hitting me with lasers where its happening.
 

·
Premium Member
Joined
·
2,998 Posts
Yep... Been getting random false laser warnings a few times since installing a month ago. This is on a ValentineOne. Positive there's no cops hitting me with lasers where its happening.
some new security systems and car's collision system reflections emit lasers and that's why false laser alerts
 

·
Registered
Joined
·
58 Posts
some new security systems and car's collision system reflections emit lasers and that's why false laser alerts
While that is true, it has nothing to do with the navigation unit causing false alerts.

According to Escort, it has to do with the high voltage circuits of the backlit screen causing interference in the detector.
 

·
Registered
Joined
·
136 Posts
I never realized how easy it was to hardwire a radar detector these days. Using the MirrorTap, I was able to tap into the rear-view mirror in literally about 15 seconds. For my Q50S Hybrid, with the Navigation and Technology package, Black is ground and Green is ignition power. They are in the same row (the row with three wires) closest to the retaining clip. Green is at the end of the connector row, black in the middle (but last of the three cables in this row). If you do not have the same package as my car, do not rely on those colors, as I know for a fact non-Tech cars have different wiring configuration on the rear-view mirror.

I also picked up the BlendMount, and installed it. It also installed relatively easily. All in all, I had everything looking professionally and factory-installed in under a half hour. I couldn't be more happy with the set up, and the customer service I experienced with BlendMount and MirrorTap was one of the best experiences, bar-none.

Here are the part numbers I ordered:
BlendMount BV1-2012 - $89.99
MACRO MirrorTap MT-3009 - $29.99
Coupon code "friend" 12.5% off - ($15.00)
No tax
Shipping $6.90
Total $111.88
Totally worth it for the clean and factory looking installation. Links to buy click here.

Pictures follow:













I hard wired my V1 and I can't get it "sit" facing forward, instead it has an upward angle. I attached a photo.
 

Attachments

·
Registered
Joined
·
58 Posts
I hard wired my V1 and I can't get it "sit" facing forward, instead it has an upward angle. I attached a photo.
Your mirror likely has 2 ball-and-joint connectors. You may find that if you grip the mirror differently than normal (or look behind it and use what you see as a guide) that you can rotate it one way that will make the mirror point at a wrong angle, but the detector at the right angle, and then you can grip the mirror as you normally do and move it back to the correct angle without moving the detector.

It sounds complicated, but it's not once you look behind it and see what I mean. And, of course, YMMV, but that's what worked for me.

Good luck!
 

·
Registered
Joined
·
136 Posts
Your mirror likely has 2 ball-and-joint connectors. You may find that if you grip the mirror differently than normal (or look behind it and use what you see as a guide) that you can rotate it one way that will make the mirror point at a wrong angle, but the detector at the right angle, and then you can grip the mirror as you normally do and move it back to the correct angle without moving the detector.

It sounds complicated, but it's not once you look behind it and see what I mean. And, of course, YMMV, but that's what worked for me.

Good luck!
Fixed! Thanks!
 

·
Registered
Joined
·
1,489 Posts
My V1's ancient suction cups finally gave up, this weekend. So I looked around for alternatives:

Blendmount- $89 plus shipping
MirrorMount- $45 plus shipping
Valentine replacement suction cups (4 in set)- $1.00 plus free shipping

As nice as the Blendmount is, I can't bring myself to pay that much when $1 fixes the problem. I'll use the 2 extra cups on my other V1.

Sometimes cheap is good enough.
 

·
Premium Member
Joined
·
2,998 Posts
My V1's ancient suction cups finally gave up, this weekend. So I looked around for alternatives:

Blendmount- $89 plus shipping
MirrorMount- $45 plus shipping
Valentine replacement suction cups (4 in set)- $1.00 plus free shipping

As nice as the Blendmount is, I can't bring myself to pay that much when $1 fixes the problem. I'll use the 2 extra cups on my other V1.

Sometimes cheap is good enough.
not "good enough" for me. I used to use suction cups... I have bunch ...
The suction cups generally are good but loosen up with heat and vibration added to my investing in blend mount and with discount, it's been pleasure to drive for blend mount discount, click below.
http://blendmount.refr.cc/HM44N8B
 

·
Registered
Joined
·
9 Posts
So follow-up from my post from last month. I contacted J28 (MirrorTap) and they promptly sent me smaller leads, and those fit perfectly. Great customer services at the MirrorTap folks.

I'm installed and mounted, and so happy.

What wires did you use? I tried the black, and the grey on the other side of the connector and got nothing...

So it would have been this
OOXOO
0YOOO

Where X=Black and Y= Grey.

That is looking at the back of the adapter. Is that the right cables?
 

·
Premium Member
Joined
·
95 Posts
I waited a while before pulling the trigger. BlendMount and MirrorTap (0.040" to black/grey leads on mirror) for Passport Max2 with built-in Bluetooth and ProClip for iPhone running Escort Live App. No problems with GPS or "falling". No cords. Yeah, I know... Better late than never. A kind thank you to all who took the plunge and shared their experiences here. :)
 

·
Registered
Joined
·
238 Posts
Blend Mount is def very cool to have.. just a suggestion for anyone who has issues with their suction cups and doesn't want to buy new ones or upgrade to a different mount.. Try spraying them with some windex and wiping them off.. Very simple and I've been able to restore the life of all my suction cups in the past :)
 

·
Registered
Joined
·
204 Posts
Hey. I bought the eBay version of the mount from performance package. Im having trouble and don't know where to insert the black and red wires. Red wire is supposed to connect to +12VDC and the black wire to a ground contact. Im not sure which one goes where. Please help if you know. I have a Q50 premium with nav and deluxe touring.
 

Attachments

·
Premium Member
Joined
·
881 Posts
On mine same as OP it was the top row. You can't see it in the pictures you posted.

Middle one is ground and far left is 12v. Far right is empty. It's only three wires in that row.
 
101 - 120 of 151 Posts
Top