Infiniti Q50 Forum banner
1 - 17 of 17 Posts

·
Registered
2018 Q50 RS AWD
Joined
·
123 Posts
Discussion Starter · #1 · (Edited)
So today while doing a 3rd gear pull, I heard a noise I have never heard before. Once I hit WOT at around 3k-3.5k RPMs, a whistle noise came from the car. Its not super loud, but it was very evident. I attached a clip so you can hear it. It is not a steady whistle, as the tone or pitch kind of oscillates, not sure if you can pick up on that in the video or not.

The reason I was doing the pull was to evaluate the log as I just added my EWG wires to my JB4 over the weekend. I will attach a pic of that as well for good measure. The car still seemed to build boost and pull ok, but after reading through the turbo failure thread, I saw a lot of folks in there say it all started with a whistle.

I am sure the consensus will be to take it in to be looked at, which I plan to do, but was curious if anyone has heard this or recognizes the noise. Currently at 51k miles, so worst case scenario, hopefully anything major would be covered under warranty.

Rectangle Slope Purple Font Line


 

·
Registered
Joined
·
1,979 Posts
Turbos will likely need to be replaced. That is one of the common symptoms.

 

·
Registered
St. Louis, MO
Joined
·
665 Posts
Turbos will likely need to be replaced. That is one of the common symptoms.

Let us know what they say when you bring it in. Mine makes this noise on occasion (Also 2018 Luxe w/JB4, EWG). Mine is about to hit 60k. They must have the turbo manufacturer by the nuts to replace these so easily for a tiny noise like that!
 

·
Registered
2018 Q50 RS AWD
Joined
·
123 Posts
Discussion Starter · #4 ·
I will certainly keep you all posted. This morning on my way to work I put it in map 0 and did a quick pull in 3rd once it was warmed up, still made the same noise.
 

·
Registered
Joined
·
1,979 Posts
Just because it is a "tiny noise"now doesn't mean it won't turn into a major issue in another 20k or 30k, miles. The reality is that it is a symptom of a defect or failure and should be corrected.
 

·
Registered
Joined
·
1,979 Posts
I will certainly keep you all posted. This morning on my way to work I put it in map 0 and did a quick pull in 3rd once it was warmed up, still made the same noise.
Yes, it has nothing to do with the jb4 or any map you run.
 

·
Administrator
Newport, Oregon
Joined
·
14,702 Posts
Sounds like turbo replacement time to me.
 

·
Registered
2018 Q50 RS AWD
Joined
·
123 Posts
Discussion Starter · #8 ·
And I just got the EWG wires hooked up this past weekend, lol, now I have to take those off, along with the FW.

The only other mod I would have any potential concern over would be the LDP, but as many have said on the various threads, they should not have any bearing on a warranty claim.
 

·
Registered
2018 Q50 RS AWD
Joined
·
123 Posts
Discussion Starter · #9 ·
So I finally dropped it off this morning. They called me back this afternoon and said they wanted to keep it another day. They stated they do hear the noise I am describing, but aren't yet sure if it is normal or not. He also stated something about wanting to do more testing tomorrow after a cold start with the master technician. I thought that was odd...if you hear the noise now, not sure what will change tomorrow, but I am no expert. I sure hope they don't try to tell me its normal.
 

·
Registered
Joined
·
1,979 Posts
LOL, maybe they will arrive at the right conclusion, i.e. turbo replacement. However, I'd be prepared to pushback if they claim its normal, or go to another dealer.
 

·
Registered
2018 Q50 RS AWD
Joined
·
123 Posts
Discussion Starter · #11 ·
Talked to the rep earlier, said they for sure think one is going bad. He then called me back 2 hours later and said they are just going to go ahead and replace both of them so we don't have to go through this again, potentially, in the near future.

I am gonna pick it back up tomorrow, as they need 2-3 weeks to get the parts in, but looks like both will in fact be replaced! Once it is all done, I will update the necessary info to have the Turbo Replacement Thread updated.
 

·
Administrator
Newport, Oregon
Joined
·
14,702 Posts
Talked to the rep earlier, said they for sure think one is going bad. He then called me back 2 hours later and said they are just going to go ahead and replace both of them so we don't have to go through this again, potentially, in the near future.

I am gonna pick it back up tomorrow, as they need 2-3 weeks to get the parts in, but looks like both will in fact be replaced! Once it is all done, I will update the necessary info to have the Turbo Replacement Thread updated.
How many miles on your RS?
 

·
Registered
2018 Q50 RS AWD
Joined
·
123 Posts
Discussion Starter · #13 ·
51k
 

·
Registered
2018 Q50 RS AWD
Joined
·
123 Posts
Discussion Starter · #14 ·
I was also thinking about having them install the Infiniti/AMS HE this spring, I guess this would be as good a time as ever...
 

·
Administrator
Newport, Oregon
Joined
·
14,702 Posts

·
Registered
Joined
·
1,979 Posts
Hopefully, I have a few more miles before it's my turn to replace turbos.
I can tell you from experience that mileage seems to be random when it comes to these turbo failures.
 

·
Administrator
Newport, Oregon
Joined
·
14,702 Posts
I can tell you from experience that mileage seems to be random when it comes to these turbo failures.
That's what concerns me.
 
1 - 17 of 17 Posts
Top